dependencies: bumped / freeze some libraries to make rhodecode-tools/vcsserver in sync...
dependencies: bumped / freeze some libraries to make rhodecode-tools/vcsserver in sync - pyparsing-2.4.5 - pyasn1-0.4.8 - pluggy-0.13.1 - contextlib2-0.6.0.post1 - attrs-19.3.0

File last commit:

r4113:10cc3443 default
r4113:10cc3443 default
Show More
requirements.txt
122 lines | 2.5 KiB | text/plain | TextLexer
## dependencies
amqp==2.5.2
babel==1.3
beaker==1.9.1
bleach==3.1.0
celery==4.3.0
channelstream==0.5.2
click==7.0
colander==1.7.0
# our custom configobj
https://code.rhodecode.com/upstream/configobj/artifacts/download/0-012de99a-b1e1-4f64-a5c0-07a98a41b324.tar.gz?md5=6a513f51fe04b2c18cf84c1395a7c626#egg=configobj==5.0.6
cssselect==1.0.3
cryptography==2.6.1
decorator==4.1.2
deform==2.0.8
docutils==0.14.0
dogpile.cache==0.9.0
dogpile.core==0.4.1
formencode==1.2.4
future==0.14.3
futures==3.0.2
infrae.cache==1.0.1
iso8601==0.1.12
itsdangerous==0.24
kombu==4.6.6
lxml==4.2.5
mako==1.1.0
markdown==2.6.11
markupsafe==1.1.1
msgpack-python==0.5.6
pyotp==2.3.0
packaging==19.2
pathlib2==2.3.5
paste==3.2.1
pastedeploy==2.0.1
pastescript==3.2.0
peppercorn==0.6
psutil==5.6.5
py-bcrypt==0.4
pycurl==7.43.0.3
pycrypto==2.6.1
pygments==2.4.2
pyparsing==2.4.5
pyramid-debugtoolbar==4.5.1
pyramid-mako==1.1.0
pyramid==1.10.4
pyramid_mailer==0.15.1
python-dateutil==2.8.1
python-ldap==3.1.0
python-memcached==1.59
python-pam==1.8.4
python-saml==2.4.2
pytz==2019.2
tzlocal==1.5.1
pyzmq==14.6.0
py-gfm==0.1.4
redis==3.3.11
repoze.lru==0.7
requests==2.9.1
routes==2.4.1
simplejson==3.16.0
six==1.11.0
sqlalchemy==1.3.11
sshpubkeys==3.1.0
subprocess32==3.5.4
supervisor==4.1.0
translationstring==1.3
urllib3==1.24.1
urlobject==2.4.3
venusian==1.2.0
weberror==0.10.3
webhelpers2==2.0
webob==1.8.5
whoosh==2.7.4
wsgiref==0.1.2
zope.cachedescriptors==4.3.1
zope.deprecation==4.4.0
zope.event==4.4.0
zope.interface==4.6.0
# DB drivers
mysql-python==1.2.5
pymysql==0.8.1
pysqlite==2.8.3
psycopg2==2.8.4
# IPYTHON RENDERING
# entrypoints backport, pypi version doesn't support egg installs
https://code.rhodecode.com/upstream/entrypoints/artifacts/download/0-8e9ee9e4-c4db-409c-b07e-81568fd1832d.tar.gz?md5=3a027b8ff1d257b91fe257de6c43357d#egg=entrypoints==0.2.2.rhodecode-upstream1
nbconvert==5.3.1
nbformat==4.4.0
jupyter-client==5.0.0
jupyter-core==4.5.0
## cli tools
alembic==1.3.1
invoke==0.13.0
bumpversion==0.5.3
## http servers
gevent==1.4.0
greenlet==0.4.15
gunicorn==19.9.0
waitress==1.3.1
## debug
ipdb==0.12.0
ipython==5.1.0
## rhodecode-tools, special case
https://code.rhodecode.com/rhodecode-tools-ce/artifacts/download/0-2e546668-61c4-42b2-ae03-7850a2dbb846.tar.gz?sha256=0938220f33264b0514dc63207ce1f77e38b1b1fd93fd4f68d34243ab62ecc853#egg=rhodecode-tools==1.3.0
## appenlight
appenlight-client==0.6.26
## test related requirements
-r requirements_test.txt
## uncomment to add the debug libraries
#-r requirements_debug.txt