##// END OF EJS Templates
pull-requests: optimize db transaction logic....
pull-requests: optimize db transaction logic. - we've been investigating this issue with locked pull-requests - the transactions arround audit-logs and state-lock seems to be fragile for long-running, and exception prone setups - this change tries to make use of few snapshot transactions to prevent a long ones, and actually try to recover on failed audit-log calls.

File last commit:

r3157:ea43f174 default
r4712:412d5d47 stable
Show More
node-default.nix
16 lines | 476 B | text/x-nix | NixLexer
# This file has been generated by node2nix 1.6.0. Do not edit!
{pkgs ? import <nixpkgs> {
inherit system;
}, system ? builtins.currentSystem, nodejs ? pkgs."nodejs-8_x"}:
let
nodeEnv = import ./node-env.nix {
inherit (pkgs) stdenv python2 utillinux runCommand writeTextFile;
inherit nodejs;
libtool = if pkgs.stdenv.isDarwin then pkgs.darwin.cctools else null;
};
in
import ./node-packages.nix {
inherit (pkgs) fetchurl fetchgit;
inherit nodeEnv;
}