release: Finish preparation for 4.16.0
release: Finish preparation for 4.16.0

File last commit

r3487:1c052980 default
r3500:79774464 v4.16.0 stable
Show More
requirements.txt
135 lines | 2.8 KiB | text/plain | TextLexer
/ requirements.txt
## dependencies
setuptools-scm==2.1.0
amqp==2.3.1
# not released authomatic that has updated some oauth providers
https://code.rhodecode.com/upstream/authomatic/archive/90a9ce60cc405ae8a2bf5c3713acd5d78579a04e.tar.gz?md5=3c68720a1322b25254009518d1ff6801#egg=authomatic==0.1.0.post1
atomicwrites==1.2.1
attrs==18.2.0
babel==1.3
beaker==1.9.1
bleach==3.0.2
celery==4.1.1
chameleon==2.24
channelstream==0.5.2
click==7.0
colander==1.5.1
# our custom configobj
https://code.rhodecode.com/upstream/configobj/archive/a11ff0a0bd4fbda9e3a91267e720f88329efb4a6.tar.gz?md5=9916c524ea11a6c418217af6b28d4b3c#egg=configobj==5.0.6
cssselect==1.0.3
decorator==4.1.2
deform==2.0.7
docutils==0.14.0
dogpile.cache==0.7.1
dogpile.core==0.4.1
ecdsa==0.13
formencode==1.2.4
future==0.14.3
futures==3.0.2
gnureadline==6.3.8
infrae.cache==1.0.1
iso8601==0.1.12
itsdangerous==0.24
jinja2==2.9.6
billiard==3.5.0.3
kombu==4.2.1
lxml==4.2.5
mako==1.0.7
markdown==2.6.11
markupsafe==1.1.0
msgpack-python==0.5.6
pyotp==2.2.7
packaging==15.2
paste==3.0.5
pastedeploy==2.0.1
pastescript==3.0.0
pathlib2==2.3.3
peppercorn==0.6
psutil==5.4.8
py-bcrypt==0.4
pycrypto==2.6.1
pycurl==7.43.0.2
pyflakes==0.8.1
pygments==2.3.1
pyparsing==2.3.0
pyramid-beaker==0.8
pyramid-debugtoolbar==4.5.0
pyramid-jinja2==2.7
pyramid-mako==1.0.2
pyramid==1.10.1
pyramid_mailer==0.15.1
python-dateutil
python-ldap==3.1.0
python-memcached==1.59
python-pam==1.8.4
python-saml==2.4.2
pytz==2018.4
tzlocal==1.5.1
pyzmq==14.6.0
py-gfm==0.1.4
redis==2.10.6
repoze.lru==0.7
requests==2.9.1
routes==2.4.1
simplejson==3.16.0
six==1.11.0
sqlalchemy==1.1.18
sshpubkeys==2.2.0
subprocess32==3.5.3
supervisor==3.3.5
tempita==0.5.2
translationstring==1.3
urllib3==1.24.1
urlobject==2.4.3
venusian==1.2.0
weberror==0.10.3
webhelpers2==2.0
webhelpers==1.3
webob==1.8.4
whoosh==2.7.4
wsgiref==0.1.2
zope.cachedescriptors==4.3.1
zope.deprecation==4.3.0
zope.event==4.3.0
zope.interface==4.5.0
# DB drivers
mysql-python==1.2.5
pymysql==0.8.1
pysqlite==2.8.3
psycopg2==2.7.5
# IPYTHON RENDERING
# entrypoints backport, pypi version doesn't support egg installs
https://code.rhodecode.com/upstream/entrypoints/archive/96e6d645684e1af3d7df5b5272f3fe85a546b233.tar.gz?md5=7db37771aea9ac9fefe093e5d6987313#egg=entrypoints==0.2.2.rhodecode-upstream1
nbconvert==5.3.1
nbformat==4.4.0
jupyter_client==5.0.0
## cli tools
alembic==1.0.5
invoke==0.13.0
bumpversion==0.5.3
## http servers
gevent==1.4.0
greenlet==0.4.15
gunicorn==19.9.0
waitress==1.1.0
setproctitle==1.1.10
## debug
ipdb==0.11.0
ipython==5.1.0
## rhodecode-tools, special case
https://code.rhodecode.com/rhodecode-tools-ce/archive/v1.2.1.tar.gz?md5=25bc2f7de1da318e547236d3fb463d28#egg=rhodecode-tools==1.2.1
## appenlight
appenlight-client==0.6.26
## test related requirements
-r requirements_test.txt
## uncomment to add the debug libraries
#-r requirements_debug.txt