##// END OF EJS Templates
files: use ref names in the url, and make usage of default landing refs....
files: use ref names in the url, and make usage of default landing refs. - fixes #5601 - cleanup file edit/delete/add to use common breadcrumbs functions - make the urls with ref names persistent in case we have the landing ref selected - in most cases we only want to show refs instead of full commit-id, this is how other types of tools work anyway

File last commit:

r3217:3c1a164b default
r4372:7db766f9 stable
Show More
shell-generate.nix
55 lines | 1.0 KiB | text/x-nix | NixLexer
{ pkgs ? (import <nixpkgs> {})
, pythonPackages ? "python27Packages"
}:
with pkgs.lib;
let _pythonPackages = pythonPackages; in
let
pythonPackages = getAttr _pythonPackages pkgs;
pip2nix = import ./nix-common/pip2nix.nix {
inherit
pkgs
pythonPackages;
};
in
pkgs.stdenv.mkDerivation {
name = "pip2nix-generated";
buildInputs = [
# Allows to generate python packages
pip2nix.pip2nix
pythonPackages.pip-tools
# Allows to generate node dependencies
pkgs.nodePackages.node2nix
# We need mysql_config to be around
pkgs.mysql
# We need postgresql to be around
pkgs.postgresql
# we need the below for saml
pkgs.libxml2
pkgs.libxslt
pkgs.xmlsec
# Curl is needed for pycurl
pkgs.curl
];
shellHook = ''
runHook preShellHook
runHook postShellHook
'';
preShellHook = ''
echo "Starting Generate Shell"
# Custom prompt to distinguish from other dev envs.
export PS1="\n\[\033[1;32m\][Generate-shell:\w]$\[\033[0m\] "
export PYCURL_SSL_LIBRARY=openssl
'';
}