Added tag v4.10.3 for changeset 68baee10e698
Added tag v4.10.3 for changeset 68baee10e698

File last commit:

r2158:24e0f4b8 default
r2240:9fd5b2ec stable
Show More
requirements.txt
138 lines | 2.9 KiB | text/plain | TextLexer
## core
setuptools==30.1.0
setuptools-scm==1.15.0
amqplib==1.0.2
anyjson==0.3.3
authomatic==0.1.0.post1
Babel==1.3
Beaker==1.9.0
celery==2.2.10
Chameleon==2.24
channelstream==0.5.2
click==5.1
colander==1.3.3
configobj==5.0.6
cssselect==1.0.1
decorator==4.0.11
deform==2.0.4
docutils==0.13.1
dogpile.cache==0.6.4
dogpile.core==0.4.1
ecdsa==0.13
FormEncode==1.2.4
future==0.14.3
futures==3.0.2
gnureadline==6.3.3
infrae.cache==1.0.1
iso8601==0.1.11
itsdangerous==0.24
Jinja2==2.7.3
kombu==1.5.1
lxml==3.7.3
Mako==1.0.7
Markdown==2.6.8
MarkupSafe==0.23
meld3==1.0.2
msgpack-python==0.4.8
MySQL-python==1.2.5
nose==1.3.6
objgraph==3.1.0
packaging==15.2
Paste==2.0.3
PasteDeploy==1.5.2
PasteScript==1.7.5
pathlib2==2.3.0
peppercorn==0.5
psutil==4.3.1
psycopg2==2.7.1
py-bcrypt==0.4
pycrypto==2.6.1
pycurl==7.19.5
pyflakes==0.8.1
pygments-markdown-lexer==0.1.0.dev39
Pygments==2.2.0
pyparsing==1.5.7
pyramid-beaker==0.8
pyramid-debugtoolbar==4.2.1
pyramid-jinja2==2.5
pyramid-mako==1.0.2
pyramid==1.9.1
pysqlite==2.8.3
python-dateutil==2.1
python-ldap==2.4.40
python-memcached==1.58
python-pam==1.8.2
pytz==2015.4
pyzmq==14.6.0
recaptcha-client==1.0.6
redis==2.10.6
repoze.lru==0.6
requests==2.9.1
Routes==1.13
setproctitle==1.1.8
simplejson==3.11.1
six==1.9.0
Sphinx==1.2.2
SQLAlchemy==1.1.11
sshpubkeys==2.2.0
subprocess32==3.2.7
supervisor==3.3.3
Tempita==0.5.2
translationstring==1.3
trollius==1.0.4
urllib3==1.16
URLObject==2.4.0
venusian==1.1.0
WebError==0.10.3
WebHelpers2==2.0
WebHelpers==1.3
WebOb==1.7.3
Whoosh==2.7.4
wsgiref==0.1.2
zope.cachedescriptors==4.0.0
zope.deprecation==4.1.2
zope.event==4.0.3
zope.interface==4.1.3
## customized/patched libs
# our patched version of Pylons==1.0.2
https://code.rhodecode.com/upstream/pylons/archive/707354ee4261b9c10450404fc9852ccea4fd667d.tar.gz?md5=f26633726fa2cd3a340316ee6a5d218f#egg=Pylons==1.0.2.rhodecode-patch-1
# not released py-gfm==0.1.3
https://code.rhodecode.com/upstream/py-gfm/archive/0d66a19bc16e3d49de273c0f797d4e4781e8c0f2.tar.gz?md5=0d0d5385bfb629eea636a80b9c2bfd16#egg=py-gfm==0.1.3.rhodecode-upstream1
# IPYTHON RENDERING
# entrypoints backport, pypi version doesn't support egg installs
https://code.rhodecode.com/upstream/entrypoints/archive/96e6d645684e1af3d7df5b5272f3fe85a546b233.tar.gz?md5=7db37771aea9ac9fefe093e5d6987313#egg=entrypoints==0.2.2.rhodecode-upstream1
nbconvert==5.1.1
bleach==1.5.0
nbformat==4.3.0
jupyter_client==5.0.0
## cli tools
alembic==0.9.2
invoke==0.13.0
bumpversion==0.5.3
transifex-client==0.10
## http servers
gevent==1.2.2
greenlet==0.4.12
gunicorn==19.7.1
waitress==1.0.2
uWSGI==2.0.15
## debug
ipdb==0.10.3
ipython==5.1.0
CProfileV==1.0.7
bottle==0.12.8
## rhodecode-tools, special case
https://code.rhodecode.com/rhodecode-tools-ce/archive/v0.13.0.tar.gz?md5=f937b0cb34d0779103895a5ec5689ee4#egg=rhodecode-tools==0.13.0
## appenlight
appenlight-client==0.6.21
## test related requirements
-r requirements_test.txt