##// END OF EJS Templates
caches: use a gevent compatible file-lock mechanism....
caches: use a gevent compatible file-lock mechanism. - because of gevent we can run into a deadlock situation and worker freeze because of each of the workers will try to aquire a lock. - This should help with the issue and gevent.

File last commit:

r2824:5ac461b5 default
r2878:bb23dd31 default
Show More
node-default.nix
16 lines | 476 B | text/x-nix | NixLexer
# This file has been generated by node2nix 1.5.3. Do not edit!
{pkgs ? import <nixpkgs> {
inherit system;
}, system ? builtins.currentSystem, nodejs ? pkgs."nodejs-6_x"}:
let
nodeEnv = import ./node-env.nix {
inherit (pkgs) stdenv python2 utillinux runCommand writeTextFile;
inherit nodejs;
libtool = if pkgs.stdenv.isDarwin then pkgs.darwin.cctools else null;
};
in
import ./node-packages.nix {
inherit (pkgs) fetchurl fetchgit;
inherit nodeEnv;
}