##// END OF EJS Templates
mercurial: Explicitly disable largefiles extension when no config value is present for it....
mercurial: Explicitly disable largefiles extension when no config value is present for it. Recent mercurial versions enable the largefiles extension in the hgrc file when cloning from a repo that uses largefiles. This may lead to undesired behaviour. By explicitly disabling it in the baseui object we override the setting in the hgrc file.

File last commit:

r34:640a4096 default
r36:368b34ff default
Show More
shell.nix
18 lines | 317 B | text/x-nix | NixLexer
{ pkgs ? import <nixpkgs> {}
, doCheck ? false
}:
let
vcsserver = import ./default.nix {
inherit
doCheck
pkgs;
};
in vcsserver.override (attrs: {
# Avoid that we dump any sources into the store when entering the shell and
# make development a little bit more convenient.
src = null;
})