##// END OF EJS Templates
mercurial: replace ancestor to pure python version for hg 4.1 compatability problems....
mercurial: replace ancestor to pure python version for hg 4.1 compatability problems. this was moved now to debugcommands, but we don't need to run it via commands as the code is very simple.

File last commit:

r138:3ff52ce0 default
r163:41539c12 default
Show More
python-packages-overrides.nix
47 lines | 1.4 KiB | text/x-nix | NixLexer
/ pkgs / python-packages-overrides.nix
# Overrides for the generated python-packages.nix
#
# This function is intended to be used as an extension to the generated file
# python-packages.nix. The main objective is to add needed dependencies of C
# libraries and tweak the build instructions where needed.
{ pkgs, basePythonPackages }:
let
sed = "sed -i";
in
self: super: {
subvertpy = super.subvertpy.override (attrs: {
# TODO: johbo: Remove the "or" once we drop 16.03 support
SVN_PREFIX = "${pkgs.subversion.dev or pkgs.subversion}";
propagatedBuildInputs = attrs.propagatedBuildInputs ++ [
pkgs.aprutil
pkgs.subversion
];
preBuild = pkgs.lib.optionalString pkgs.stdenv.isDarwin ''
${sed} -e "s/'gcc'/'clang'/" setup.py
'';
});
mercurial = super.mercurial.override (attrs: {
propagatedBuildInputs = attrs.propagatedBuildInputs ++ [
self.python.modules.curses
] ++ pkgs.lib.optional pkgs.stdenv.isDarwin
pkgs.darwin.apple_sdk.frameworks.ApplicationServices;
});
pyramid = super.pyramid.override (attrs: {
postFixup = ''
wrapPythonPrograms
# TODO: johbo: "wrapPython" adds this magic line which
# confuses pserve.
${sed} '/import sys; sys.argv/d' $out/bin/.pserve-wrapped
'';
});
# Avoid that setuptools is replaced, this leads to trouble
# with buildPythonPackage.
setuptools = basePythonPackages.setuptools;
}