##// END OF EJS Templates
http: Add error handling for the repo-locked exception. Part of #4237...
http: Add error handling for the repo-locked exception. Part of #4237 Previously the repo locekd exception was raised on return of the call to the hooks daemon and propagates all the way up to the WSGI server (e.g. waitress). In case of locked repos we want to return a custom response which contains an explanation for the user that the repo is locked and who has locked it.

File last commit:

r34:640a4096 default
r85:a0c3f57b default
Show More
shell.nix
18 lines | 317 B | text/x-nix | NixLexer
{ pkgs ? import <nixpkgs> {}
, doCheck ? false
}:
let
vcsserver = import ./default.nix {
inherit
doCheck
pkgs;
};
in vcsserver.override (attrs: {
# Avoid that we dump any sources into the store when entering the shell and
# make development a little bit more convenient.
src = null;
})