##// END OF EJS Templates
dependencies: bumped few libraries....
dependencies: bumped few libraries. - atomicwrites==1.2.1 - attrs==18.2.0 - dogpile.cache==0.6.7 - psutil==5.4.7 - pathlib2==2.3.2 - subprocess32==3.5.2 - gevent==1.3.6 - greenlet==0.4.15 - pytest==3.8.1 - py==1.6.0 - pytest-cov==2.6.0 - pytest-timeout==1.3.2 - coverage==4.5.1

File last commit:

r472:c4583ce6 default
r556:bab76a39 default
Show More
shell-generate.nix
41 lines | 849 B | text/x-nix | NixLexer
{ pkgs ? (import <nixpkgs> {})
, pythonPackages ? "python27Packages"
}:
with pkgs.lib;
let _pythonPackages = pythonPackages; in
let
pythonPackages = getAttr _pythonPackages pkgs;
pip2nix = import ./nix-common/pip2nix.nix {
inherit
pkgs
pythonPackages;
};
in
pkgs.stdenv.mkDerivation {
name = "pip2nix-generated";
buildInputs = [
pip2nix.pip2nix
pythonPackages.pip-tools
pkgs.apr
pkgs.aprutil
];
shellHook = ''
runHook preShellHook
echo "Setting SVN_* variables"
export SVN_LIBRARY_PATH=${pkgs.subversion}/lib
export SVN_HEADER_PATH=${pkgs.subversion.dev}/include
runHook postShellHook
'';
preShellHook = ''
echo "Starting Generate Shell"
# Custom prompt to distinguish from other dev envs.
export PS1="\n\[\033[1;32m\][Generate-shell:\w]$\[\033[0m\] "
'';
}