##// END OF EJS Templates
stream: use wsgi.input_terminated because of webob changes of handling chunked encoding
stream: use wsgi.input_terminated because of webob changes of handling chunked encoding

File last commit:

r320:b2ca4cbc default
r343:ed48ec99 default
Show More
python-packages-overrides.nix
54 lines | 1.5 KiB | text/x-nix | NixLexer
/ pkgs / python-packages-overrides.nix
# Overrides for the generated python-packages.nix
#
# This function is intended to be used as an extension to the generated file
# python-packages.nix. The main objective is to add needed dependencies of C
# libraries and tweak the build instructions where needed.
{ pkgs, basePythonPackages }:
let
sed = "sed -i";
in
self: super: {
subvertpy = super.subvertpy.override (attrs: {
# TODO: johbo: Remove the "or" once we drop 16.03 support
SVN_PREFIX = "${pkgs.subversion.dev or pkgs.subversion}";
propagatedBuildInputs = attrs.propagatedBuildInputs ++ [
pkgs.aprutil
pkgs.subversion
];
preBuild = pkgs.lib.optionalString pkgs.stdenv.isDarwin ''
${sed} -e "s/'gcc'/'clang'/" setup.py
'';
});
hgsubversion = super.hgsubversion.override (attrs: {
propagatedBuildInputs = attrs.propagatedBuildInputs ++ [
pkgs.sqlite
basePythonPackages.sqlite3
];
});
mercurial = super.mercurial.override (attrs: {
propagatedBuildInputs = attrs.propagatedBuildInputs ++ [
self.python.modules.curses
] ++ pkgs.lib.optional pkgs.stdenv.isDarwin
pkgs.darwin.apple_sdk.frameworks.ApplicationServices;
});
pyramid = super.pyramid.override (attrs: {
postFixup = ''
wrapPythonPrograms
# TODO: johbo: "wrapPython" adds this magic line which
# confuses pserve.
${sed} '/import sys; sys.argv/d' $out/bin/.pserve-wrapped
'';
});
# Avoid that setuptools is replaced, this leads to trouble
# with buildPythonPackage.
setuptools = basePythonPackages.setuptools;
}