Add deprecationwarning with stacklevel
Sourav Singh -
r24146:8f9be5ca
Not Reviewed
Show More
Add another comment
TODOs: 0 unresolved 0 Resolved
COMMENTS: 0 General 0 Inline
@@ -7,6 +7,6 Shim to maintain backwards compatibility with old IPython.consoleapp imports.
7 from warnings import warn
7 from warnings import warn
8
8
9 warn("The `IPython.consoleapp` package has been deprecated. "
9 warn("The `IPython.consoleapp` package has been deprecated. "
10 "You should import from jupyter_client.consoleapp instead.")
10 "You should import from jupyter_client.consoleapp instead.", DeprecationWarning, stacklevel=2)
11
11
12 from jupyter_client.consoleapp import *
12 from jupyter_client.consoleapp import *
Comments 0
You need to be logged in to leave comments. Login now