Merge pull request #12410 from Carreau/nep29
Matthias Bussonnier -
r25874:bb015d48 merge
Not Reviewed
Show More
Add another comment
TODOs: 0 unresolved 0 Resolved
COMMENTS: 0 General 0 Inline
@@ -34,6 +34,11 before_install:
34 install:
34 install:
35 - pip install pip --upgrade
35 - pip install pip --upgrade
36 - pip install setuptools --upgrade
36 - pip install setuptools --upgrade
37 - if [[ "$TRAVIS_PYTHON_VERSION" == "3.6" ]]; then
38 echo "for the tiem being still test on 3.6";
39 sed -i bkp s/7/6/g setup.py;
40 git diff;
41 fi
37 - pip install -e file://$PWD#egg=ipython[test] --upgrade
42 - pip install -e file://$PWD#egg=ipython[test] --upgrade
38 - pip install trio curio --upgrade --upgrade-strategy eager
43 - pip install trio curio --upgrade --upgrade-strategy eager
39 - pip install pytest 'matplotlib !=3.2.0' mypy
44 - pip install pytest 'matplotlib !=3.2.0' mypy
@@ -24,7 +24,7 import sys
24 #
24 #
25 # This check is also made in IPython/__init__, don't forget to update both when
25 # This check is also made in IPython/__init__, don't forget to update both when
26 # changing Python version requirements.
26 # changing Python version requirements.
27 if sys.version_info < (3, 6):
27 if sys.version_info < (3, 7):
28 pip_message = 'This may be due to an out of date pip. Make sure you have pip >= 9.0.1.'
28 pip_message = 'This may be due to an out of date pip. Make sure you have pip >= 9.0.1.'
29 try:
29 try:
30 import pip
30 import pip
@@ -40,10 +40,11 if sys.version_info < (3, 6):
40
40
41
41
42 error = """
42 error = """
43 IPython 7.10+ supports Python 3.6 and above, following NEP 29.
43 IPython 7.17+ supports Python 3.7 and above, following NEP 29.
44 When using Python 2.7, please install IPython 5.x LTS Long Term Support version.
44 When using Python 2.7, please install IPython 5.x LTS Long Term Support version.
45 Python 3.3 and 3.4 were supported up to IPython 6.x.
45 Python 3.3 and 3.4 were supported up to IPython 6.x.
46 Python 3.5 was supported with IPython 7.0 to 7.9.
46 Python 3.5 was supported with IPython 7.0 to 7.9.
47 Python 3.6 was supported with IPython up to 7.16.
47
48
48 See IPython `README.rst` file for more information:
49 See IPython `README.rst` file for more information:
49
50
@@ -227,7 +228,7 for key, deps in extras_require.items():
227 extras_require['all'] = list(sorted(everything))
228 extras_require['all'] = list(sorted(everything))
228
229
229 if 'setuptools' in sys.modules:
230 if 'setuptools' in sys.modules:
230 setuptools_extra_args['python_requires'] = '>=3.6'
231 setuptools_extra_args['python_requires'] = '>=3.7'
231 setuptools_extra_args['zip_safe'] = False
232 setuptools_extra_args['zip_safe'] = False
232 setuptools_extra_args['entry_points'] = {
233 setuptools_extra_args['entry_points'] = {
233 'console_scripts': find_entry_points(),
234 'console_scripts': find_entry_points(),
Comments 0
You need to be logged in to leave comments. Login now