##// END OF EJS Templates
Fix problems with side effects and python 2.6....
Fix problems with side effects and python 2.6. The isolation decorator wasn't working correctly (side effects were leaking into other tests by breaking the user namespace). Rewrote it to instead use a simpler but more robust strategy (that is also faster). See detailed comment in source for more. I discovered that some tests were failing when running with python 2.6 because of changes in the behavior of int and the new print-as-a-function that Wx seems to activate. Updated the code to cope with both 2.5 and 2.6.

File last commit:

r1178:e29512cb
r2089:25180f38
Show More
control
26 lines | 1.4 KiB | text/plain | DebianControlLexer
Source: ipython
Section: python
Priority: optional
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders: Norbert Tretkowski <nobse@debian.org>, Bernd Zeimetz <bernd@bzed.de>
Build-Depends: debhelper (>= 5.0.37.2), dpatch (>= 2.0.10), cdbs (>= 0.4.43), python, python-support (>= 0.4)
Homepage: http://ipython.scipy.org/
Vcs-Svn: svn://svn.debian.org/python-modules/packages/ipython/trunk/
Vcs-Browser: http://svn.debian.org/wsvn/python-modules/packages/ipython/trunk/
Standards-Version: 3.7.2.2
Package: ipython
Architecture: all
Depends: ${python:Depends}, ${misc:Depends}, python-pexpect
Conflicts: python2.3-ipython, python2.4-ipython, ipython-common
Replaces: python2.3-ipython, python2.4-ipython, ipython-common
Suggests: python-profiler, python-numeric, python-numeric-ext, python-matplotlib
Description: enhanced interactive Python shell
IPython can be used as a replacement for the standard Python shell,
or it can be used as a complete working environment for scientific
computing (like Matlab or Mathematica) when paired with the standard
Python scientific and numerical tools. It supports dynamic object
introspections, numbered input/output prompts, a macro system,
session logging, session restoring, complete system shell access,
verbose and colored traceback reports, auto-parentheses, auto-quoting,
and is embeddable in other Python programs.