##// END OF EJS Templates
Make set_term_title() default to no-op, as it can cause problems....
Make set_term_title() default to no-op, as it can cause problems. In embedded contexts this can corrupt stdout (e.g. gedit ipython plugin), by default ipython should be 'safe' to use in all contexts. The user-facing terminal app can activate more aggressive configurations as needed. Added an API call to actually toggle the state, and deprecated the old one (which could only disable but not enable).

File last commit:

r1178:e29512cb
r1852:37edbe78
Show More
rules
25 lines | 1.0 KiB | text/plain | TextLexer
#!/usr/bin/make -f
# ipython debian/rules file
DEB_PYTHON_SYSTEM=pysupport
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk
include /usr/share/cdbs/1/rules/dpatch.mk
install/ipython::
# remove documentation
rm $(CURDIR)/debian/ipython/usr/share/doc/ipython/COPYING
rm $(CURDIR)/debian/ipython/usr/share/doc/ipython/ChangeLog
rm $(CURDIR)/debian/ipython/usr/share/doc/ipython/README_Windows.txt
rm $(CURDIR)/debian/ipython/usr/share/doc/ipython/pycon.ico
# change permission on scripts
chmod a-x $(CURDIR)/debian/ipython/usr/share/doc/ipython/examples/*
# removing bogus usr/IPython directory
rm -rf $(CURDIR)/debian/ipython/usr/IPython
binary-fixup/ipython::
# fix lintian warnings (see also patches/04_remove_shebang.dpatch)
chmod +x $(CURDIR)/debian/ipython/usr/share/python-support/ipython/IPython/upgrade_dir.py
chmod +x $(CURDIR)/debian/ipython/usr/share/python-support/ipython/IPython/Extensions/pickleshare.py
chmod +x $(CURDIR)/debian/ipython/usr/share/python-support/ipython/IPython/irunner.py