##// END OF EJS Templates
This is a manual merge of certain things in the ipython1-dev branch, revision 46, into the main ...
This is a manual merge of certain things in the ipython1-dev branch, revision 46, into the main ipython branch. This is not a true merge in the formal sense because all history is not coming over with the files. For a detailed history of the added files, please see the ipython1-dev branch or the svn repository on scipy.org that ipython1-dev came from. More specifically, here is what I have done in this commit: 1) Moved the following by hand ipython1.config -> IPython.config ipython1.kernel -> IPython.kernel ipython1.external -> IPython.external ipython1.core -> IPython.kernel.core ipython1.testutils -> IPython.testing ipython1.tools -> IPython.tools 2) Moved IPython.tools.guid -> IPython1.external.guid 3) Renamed: ipython1 -> IPython IPython.core -> IPython.kernel.core IPython.testutils -> IPython.testing 4) Then did a "bzr add" for all the new stuff. That is all folks!

File last commit:

r1178:e29512cb
r1234:52b55407
Show More
rules
25 lines | 1.0 KiB | text/plain | TextLexer
#!/usr/bin/make -f
# ipython debian/rules file
DEB_PYTHON_SYSTEM=pysupport
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk
include /usr/share/cdbs/1/rules/dpatch.mk
install/ipython::
# remove documentation
rm $(CURDIR)/debian/ipython/usr/share/doc/ipython/COPYING
rm $(CURDIR)/debian/ipython/usr/share/doc/ipython/ChangeLog
rm $(CURDIR)/debian/ipython/usr/share/doc/ipython/README_Windows.txt
rm $(CURDIR)/debian/ipython/usr/share/doc/ipython/pycon.ico
# change permission on scripts
chmod a-x $(CURDIR)/debian/ipython/usr/share/doc/ipython/examples/*
# removing bogus usr/IPython directory
rm -rf $(CURDIR)/debian/ipython/usr/IPython
binary-fixup/ipython::
# fix lintian warnings (see also patches/04_remove_shebang.dpatch)
chmod +x $(CURDIR)/debian/ipython/usr/share/python-support/ipython/IPython/upgrade_dir.py
chmod +x $(CURDIR)/debian/ipython/usr/share/python-support/ipython/IPython/Extensions/pickleshare.py
chmod +x $(CURDIR)/debian/ipython/usr/share/python-support/ipython/IPython/irunner.py