repository: show recomendation for updating hooks if they are outdated.
marcink -
r4290:316080ab default
Not Reviewed
Show More
Add another comment
TODOs: 0 unresolved 0 Resolved
COMMENTS: 0 General 0 Inline
@@ -22,6 +22,7
22
22
23 from pyramid.view import view_config
23 from pyramid.view import view_config
24 from pyramid.httpexceptions import HTTPFound
24 from pyramid.httpexceptions import HTTPFound
25 from packaging.version import Version
25
26
26 from rhodecode import events
27 from rhodecode import events
27 from rhodecode.apps._base import RepoAppView
28 from rhodecode.apps._base import RepoAppView
@@ -70,6 +71,13
70 .filter(UserFollowing.follows_repository == self.db_repo).scalar()
71 .filter(UserFollowing.follows_repository == self.db_repo).scalar()
71
72
72 c.ver_info_dict = self.rhodecode_vcs_repo.get_hooks_info()
73 c.ver_info_dict = self.rhodecode_vcs_repo.get_hooks_info()
74 c.hooks_outdated = False
75
76 try:
77 if Version(c.ver_info_dict['pre_version']) < Version(c.rhodecode_version):
78 c.hooks_outdated = True
79 except Exception:
80 pass
73
81
74 # update commit cache if GET flag is present
82 # update commit cache if GET flag is present
75 if self.request.GET.get('update_commit_cache'):
83 if self.request.GET.get('update_commit_cache'):
@@ -147,6 +147,11
147 onclick="return confirm('${_('Confirm to reinstall hooks for this repository.')}');">
147 onclick="return confirm('${_('Confirm to reinstall hooks for this repository.')}');">
148 ${_('Update Hooks')}
148 ${_('Update Hooks')}
149 </a>
149 </a>
150 % if c.hooks_outdated:
151 <span class="alert-error" style="padding: 10px">
152 ${_('Outdated hooks detected, please update hooks using `Update Hooks` action.')}
153 </span>
154 % endif
150 </div>
155 </div>
151 </div>
156 </div>
152
157
Comments 0
You need to be logged in to leave comments. Login now