nix: don't inject invoke/bumpversion in default shell, we use our own py3 compat, and want to have an option to skip it
marcink -
r4178:b87f1db7 default
Not Reviewed
Show More
Add another comment
TODOs: 0 unresolved 0 Resolved
COMMENTS: 0 General 0 Inline
@@ -6,6 +6,7
6 , doCheck ? false
6 , doCheck ? false
7 , sourcesOverrides ? {}
7 , sourcesOverrides ? {}
8 , doDevelopInstall ? true
8 , doDevelopInstall ? true
9 , doReleaseInstall ? false
9 }:
10 }:
10
11
11 let
12 let
@@ -69,11 +70,12
69 # Add dependencies which are useful for the development environment.
70 # Add dependencies which are useful for the development environment.
70 buildInputs =
71 buildInputs =
71 attrs.buildInputs ++
72 attrs.buildInputs ++
72 (with ce-pythonPackages; [
73 (with ce-pythonPackages;
73 bumpversion
74 [ ipdb ]
74 invoke
75 ++ pkgs.lib.lists.optionals doReleaseInstall (
75 ipdb
76 [invoke bumpversion]
76 ]);
77 )
78 );
77
79
78 # place to inject some required libs from develop installs
80 # place to inject some required libs from develop installs
79 propagatedBuildInputs =
81 propagatedBuildInputs =
Comments 0
You need to be logged in to leave comments. Login now