##// END OF EJS Templates
packages: bumped libraries and restructured requirements files...
marcink -
r137:0a697d69 default
parent child
Show More
@@ -0,0 +1,15
1 # test related requirements
2 pytest==3.0.5
3 py==1.4.31
4 pytest-cov==2.4.0
5 pytest-sugar==0.7.1
6 pytest-runner==2.9.0
7 pytest-catchlog==1.2.2
8 pytest-profiling==1.2.2
9 gprof2dot==2016.10.13
10 pytest-timeout==1.2.0
11
12 mock==1.0.1
13 WebTest==1.4.3
14 cov-core==1.15.0
15 coverage==3.7.1
@@ -1,35 +1,41
1 # core
2 setuptools==20.8.1
3
1 Beaker==1.7.0
4 Beaker==1.7.0
2 configobj==5.0.6
5 configobj==5.0.6
3 dulwich==0.13.0
6 dulwich==0.13.0
4 hgsubversion==1.8.6
7 hgsubversion==1.8.6
5 infrae.cache==1.0.1
8 infrae.cache==1.0.1
6 ipdb==0.10.1
7 mercurial==4.0.1
9 mercurial==4.0.1
8 msgpack-python==0.4.6
10 msgpack-python==0.4.8
9 py==1.4.29
10 pyramid==1.6.1
11 pyramid==1.6.1
11 pyramid-jinja2==2.5
12 pyramid-jinja2==2.5
12 pyramid-mako==1.0.2
13 pyramid-mako==1.0.2
13 Pyro4==4.41
14 pytest==2.8.5
15 repoze.lru==0.6
14 repoze.lru==0.6
16 serpent==1.12
17 setuptools==20.8.1
18 simplejson==3.7.2
15 simplejson==3.7.2
19 subprocess32==3.2.6
16 subprocess32==3.2.6
20 # TODO: johbo: This version is not in source on PyPI currently,
17
21 # change back once this or a future version is available
18 # Custom subvertpy that is not available on pypi.
22 https://github.com/jelmer/subvertpy/archive/subvertpy-0.9.3.tar.gz#md5=7b745a47128050ea5a73efcd913ec1cf
19 https://code.rhodecode.com/upstream/subvertpy/archive/subvertpy-0.9.3.tar.gz?md5=4e49da2fe07608239cc9a80a7bb8f33c#egg=subvertpy==0.9.3
20
23 six==1.9.0
21 six==1.9.0
24 translationstring==1.3
22 translationstring==1.3
25 waitress==0.8.9
26 WebOb==1.3.1
23 WebOb==1.3.1
27 wheel==0.29.0
24 wheel==0.29.0
28 zope.deprecation==4.1.1
25 zope.deprecation==4.1.2
29 zope.interface==4.1.3
26 zope.interface==4.1.3
30 greenlet==0.4.7
27
28 # debug
29 ipdb==0.10.1
30
31 # http servers
32 gevent==1.1.2
33 greenlet==0.4.10
31 gunicorn==19.6.0
34 gunicorn==19.6.0
35 waitress==1.0.1
32
36
33 # Test related requirements
37 # Pyro/Deprecated TODO(Marcink): remove in 4.7 release.
34 mock==1.0.1
38 Pyro4==4.41
35 WebTest==1.4.3
39 serpent==1.15
40
41 -r requirements_test.txt
General Comments 0
You need to be logged in to leave comments. Login now