##// END OF EJS Templates
Update shim warnings to include IPython version....
Matthias Bussonnier -
r23398:f33ca742
parent child
Show More
@@ -9,7 +9,7 from warnings import warn
9
9
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
11
11
12 warn("The `IPython.config` package has been deprecated. "
12 warn("The `IPython.config` package has been deprecated since IPython 4.0. "
13 "You should import from traitlets.config instead.", ShimWarning)
13 "You should import from traitlets.config instead.", ShimWarning)
14
14
15
15
@@ -17,7 +17,7 from warnings import warn
17
17
18 from IPython.utils.shimmodule import ShimModule, ShimWarning
18 from IPython.utils.shimmodule import ShimModule, ShimWarning
19
19
20 warn("The top-level `frontend` package has been deprecated. "
20 warn("The top-level `frontend` package has been deprecated since IPython 1.0. "
21 "All its subpackages have been moved to the top `IPython` level.", ShimWarning)
21 "All its subpackages have been moved to the top `IPython` level.", ShimWarning)
22
22
23 # Unconditionally insert the shim into sys.modules so that further import calls
23 # Unconditionally insert the shim into sys.modules so that further import calls
@@ -9,7 +9,7 from warnings import warn
9
9
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
11
11
12 warn("The `IPython.html` package has been deprecated. "
12 warn("The `IPython.html` package has been deprecated since IPython 4.0. "
13 "You should import from `notebook` instead. "
13 "You should import from `notebook` instead. "
14 "`IPython.html.widgets` has moved to `ipywidgets`.", ShimWarning)
14 "`IPython.html.widgets` has moved to `ipywidgets`.", ShimWarning)
15
15
@@ -9,7 +9,7 from warnings import warn
9
9
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
11
11
12 warn("The `IPython.kernel` package has been deprecated. "
12 warn("The `IPython.kernel` package has been deprecated since IPython 4.0."
13 "You should import from ipykernel or jupyter_client instead.", ShimWarning)
13 "You should import from ipykernel or jupyter_client instead.", ShimWarning)
14
14
15
15
@@ -9,7 +9,7 from warnings import warn
9
9
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
11
11
12 warn("The `IPython.nbconvert` package has been deprecated. "
12 warn("The `IPython.nbconvert` package has been deprecated since IPython 4.0. "
13 "You should import from nbconvert instead.", ShimWarning)
13 "You should import from nbconvert instead.", ShimWarning)
14
14
15 # Unconditionally insert the shim into sys.modules so that further import calls
15 # Unconditionally insert the shim into sys.modules so that further import calls
@@ -9,7 +9,7 from warnings import warn
9
9
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
11
11
12 warn("The `IPython.nbformat` package has been deprecated. "
12 warn("The `IPython.nbformat` package has been deprecated since IPython 4.0. "
13 "You should import from nbformat instead.", ShimWarning)
13 "You should import from nbformat instead.", ShimWarning)
14
14
15 # Unconditionally insert the shim into sys.modules so that further import calls
15 # Unconditionally insert the shim into sys.modules so that further import calls
@@ -9,7 +9,7 from warnings import warn
9
9
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
11
11
12 warn("The `IPython.parallel` package has been deprecated. "
12 warn("The `IPython.parallel` package has been deprecated since IPython 4.0. "
13 "You should import from ipyparallel instead.", ShimWarning)
13 "You should import from ipyparallel instead.", ShimWarning)
14
14
15 # Unconditionally insert the shim into sys.modules so that further import calls
15 # Unconditionally insert the shim into sys.modules so that further import calls
@@ -9,7 +9,7 from warnings import warn
9
9
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
11
11
12 warn("The `IPython.qt` package has been deprecated. "
12 warn("The `IPython.qt` package has been deprecated since IPython 4.0. "
13 "You should import from qtconsole instead.", ShimWarning)
13 "You should import from qtconsole instead.", ShimWarning)
14
14
15 # Unconditionally insert the shim into sys.modules so that further import calls
15 # Unconditionally insert the shim into sys.modules so that further import calls
@@ -9,7 +9,7 from warnings import warn
9
9
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
10 from IPython.utils.shimmodule import ShimModule, ShimWarning
11
11
12 warn("The `IPython.terminal.console` package has been deprecated. "
12 warn("The `IPython.terminal.console` package has been deprecated since IPython 4.0. "
13 "You should import from jupyter_console instead.", ShimWarning)
13 "You should import from jupyter_console instead.", ShimWarning)
14
14
15 # Unconditionally insert the shim into sys.modules so that further import calls
15 # Unconditionally insert the shim into sys.modules so that further import calls
General Comments 0
You need to be logged in to leave comments. Login now