dependencies: bumped / freeze some libraries to make rhodecode-tools/vcsserver in sync...
marcink -
r4113:10cc3443 default
Not Reviewed
Show More
Add another comment
TODOs: 0 unresolved 0 Resolved
COMMENTS: 0 General 0 Inline
@@ -74,11 +74,11
74 };
74 };
75 };
75 };
76 "attrs" = super.buildPythonPackage {
76 "attrs" = super.buildPythonPackage {
77 name = "attrs-19.1.0";
77 name = "attrs-19.3.0";
78 doCheck = false;
78 doCheck = false;
79 src = fetchurl {
79 src = fetchurl {
80 url = "https://files.pythonhosted.org/packages/cc/d9/931a24cc5394f19383fbbe3e1147a0291276afa43a0dc3ed0d6cd9fda813/attrs-19.1.0.tar.gz";
80 url = "https://files.pythonhosted.org/packages/98/c3/2c227e66b5e896e15ccdae2e00bbc69aa46e9a8ce8869cc5fa96310bf612/attrs-19.3.0.tar.gz";
81 sha256 = "16g33zr5f449lqc5wgvzpknxryfzrfsxcr6kpgxwn7l5fkv71f7h";
81 sha256 = "0wky4h28n7xnr6xv69p9z6kv8bzn50d10c3drmd9ds8gawbcxdzp";
82 };
82 };
83 meta = {
83 meta = {
84 license = [ pkgs.lib.licenses.mit ];
84 license = [ pkgs.lib.licenses.mit ];
@@ -286,11 +286,11
286 };
286 };
287 };
287 };
288 "contextlib2" = super.buildPythonPackage {
288 "contextlib2" = super.buildPythonPackage {
289 name = "contextlib2-0.6.0";
289 name = "contextlib2-0.6.0.post1";
290 doCheck = false;
290 doCheck = false;
291 src = fetchurl {
291 src = fetchurl {
292 url = "https://files.pythonhosted.org/packages/f0/08/ac376929b2c51e2d5fd4b9fa1f72eca0162c990edc526bdd3b16449323ad/contextlib2-0.6.0.tar.gz";
292 url = "https://files.pythonhosted.org/packages/02/54/669207eb72e3d8ae8b38aa1f0703ee87a0e9f88f30d3c0a47bebdb6de242/contextlib2-0.6.0.post1.tar.gz";
293 sha256 = "1lvy0xvh5kkx0cmv2y8rpxjrg909q920k05x7m8srjkpcxrsm5vi";
293 sha256 = "0bhnr2ac7wy5l85ji909gyljyk85n92w8pdvslmrvc8qih4r1x01";
294 };
294 };
295 meta = {
295 meta = {
296 license = [ pkgs.lib.licenses.psfl ];
296 license = [ pkgs.lib.licenses.psfl ];
@@ -1191,14 +1191,14
1191 };
1191 };
1192 };
1192 };
1193 "pluggy" = super.buildPythonPackage {
1193 "pluggy" = super.buildPythonPackage {
1194 name = "pluggy-0.13.0";
1194 name = "pluggy-0.13.1";
1195 doCheck = false;
1195 doCheck = false;
1196 propagatedBuildInputs = [
1196 propagatedBuildInputs = [
1197 self."importlib-metadata"
1197 self."importlib-metadata"
1198 ];
1198 ];
1199 src = fetchurl {
1199 src = fetchurl {
1200 url = "https://files.pythonhosted.org/packages/d7/9d/ae82a5facf2dd89f557a33ad18eb68e5ac7b7a75cf52bf6a208f29077ecf/pluggy-0.13.0.tar.gz";
1200 url = "https://files.pythonhosted.org/packages/f8/04/7a8542bed4b16a65c2714bf76cf5a0b026157da7f75e87cc88774aa10b14/pluggy-0.13.1.tar.gz";
1201 sha256 = "0d4gsvb4kjqhiqqi4bbsdp7s1xlyl5phibcw1q1mrpd65xia2pzs";
1201 sha256 = "1c35qyhvy27q9ih9n899f3h4sdnpgq027dbiilly2qb5cvgarchm";
1202 };
1202 };
1203 meta = {
1203 meta = {
1204 license = [ pkgs.lib.licenses.mit ];
1204 license = [ pkgs.lib.licenses.mit ];
@@ -1290,11 +1290,11
1290 };
1290 };
1291 };
1291 };
1292 "pyasn1" = super.buildPythonPackage {
1292 "pyasn1" = super.buildPythonPackage {
1293 name = "pyasn1-0.4.7";
1293 name = "pyasn1-0.4.8";
1294 doCheck = false;
1294 doCheck = false;
1295 src = fetchurl {
1295 src = fetchurl {
1296 url = "https://files.pythonhosted.org/packages/ca/f8/2a60a2c88a97558bdd289b6dc9eb75b00bd90ff34155d681ba6dbbcb46b2/pyasn1-0.4.7.tar.gz";
1296 url = "https://files.pythonhosted.org/packages/a4/db/fffec68299e6d7bad3d504147f9094830b704527a7fc098b721d38cc7fa7/pyasn1-0.4.8.tar.gz";
1297 sha256 = "0146ryp4g09ycy8p3l2vigmgfg42n4gb8whgg8cysrhxr9b56jd9";
1297 sha256 = "1fnhbi3rmk47l9851gbik0flfr64vs5j0hbqx24cafjap6gprxxf";
1298 };
1298 };
1299 meta = {
1299 meta = {
1300 license = [ pkgs.lib.licenses.bsdOriginal ];
1300 license = [ pkgs.lib.licenses.bsdOriginal ];
@@ -1381,11 +1381,11
1381 };
1381 };
1382 };
1382 };
1383 "pyparsing" = super.buildPythonPackage {
1383 "pyparsing" = super.buildPythonPackage {
1384 name = "pyparsing-2.4.2";
1384 name = "pyparsing-2.4.5";
1385 doCheck = false;
1385 doCheck = false;
1386 src = fetchurl {
1386 src = fetchurl {
1387 url = "https://files.pythonhosted.org/packages/7e/24/eaa8d7003aee23eda270099eeec754d7bf4399f75c6a011ef948304f66a2/pyparsing-2.4.2.tar.gz";
1387 url = "https://files.pythonhosted.org/packages/00/32/8076fa13e832bb4dcff379f18f228e5a53412be0631808b9ca2610c0f566/pyparsing-2.4.5.tar.gz";
1388 sha256 = "106xmhd2xn5bv6blsbqaa6wciwcq2c9i1pq1riw6s83y76wsg63g";
1388 sha256 = "0fk8gsybiw1gm146mkjdjvaajwh20xwvpv4j7syh2zrnpq0j19jc";
1389 };
1389 };
1390 meta = {
1390 meta = {
1391 license = [ pkgs.lib.licenses.mit ];
1391 license = [ pkgs.lib.licenses.mit ];
@@ -1937,11 +1937,11
1937 };
1937 };
1938 };
1938 };
1939 "setuptools" = super.buildPythonPackage {
1939 "setuptools" = super.buildPythonPackage {
1940 name = "setuptools-41.6.0";
1940 name = "setuptools-42.0.2";
1941 doCheck = false;
1941 doCheck = false;
1942 src = fetchurl {
1942 src = fetchurl {
1943 url = "https://files.pythonhosted.org/packages/11/0a/7f13ef5cd932a107cd4c0f3ebc9d831d9b78e1a0e8c98a098ca17b1d7d97/setuptools-41.6.0.zip";
1943 url = "https://files.pythonhosted.org/packages/f7/b6/5b98441b6749ea1db1e41e5e6e7a93cbdd7ffd45e11fe1b22d45884bc777/setuptools-42.0.2.zip";
1944 sha256 = "08nplghlnlb4qkhb9hp1lqqqlnh1qingdj8fi6w6rlfwj6rn3yka";
1944 sha256 = "0h5rsh8cpq9mh6kzr5xgcmyqyl8ym5r6i9m6g770k1vw1l4p5cy5";
1945 };
1945 };
1946 meta = {
1946 meta = {
1947 license = [ pkgs.lib.licenses.mit ];
1947 license = [ pkgs.lib.licenses.mit ];
@@ -41,7 +41,7
41 pycurl==7.43.0.3
41 pycurl==7.43.0.3
42 pycrypto==2.6.1
42 pycrypto==2.6.1
43 pygments==2.4.2
43 pygments==2.4.2
44 pyparsing==2.4.2
44 pyparsing==2.4.5
45 pyramid-debugtoolbar==4.5.1
45 pyramid-debugtoolbar==4.5.1
46 pyramid-mako==1.1.0
46 pyramid-mako==1.1.0
47 pyramid==1.10.4
47 pyramid==1.10.4
@@ -1,20 +1,21
1 # contains not directly required libraries we want to pin the version.
1 # contains not directly required libraries we want to pin the version.
2
2
3 atomicwrites==1.3.0
3 atomicwrites==1.3.0
4 attrs==19.1.0
4 attrs==19.3.0
5 asn1crypto==0.24.0
5 asn1crypto==0.24.0
6 billiard==3.6.1.0
6 billiard==3.6.1.0
7 cffi==1.12.3
7 cffi==1.12.3
8 chameleon==2.24
8 chameleon==2.24
9 configparser==4.0.2
9 configparser==4.0.2
10 contextlib2==0.6.0
10 contextlib2==0.6.0.post1
11 ecdsa==0.13.2
11 ecdsa==0.13.2
12 gnureadline==6.3.8
12 gnureadline==6.3.8
13 hupper==1.9.1
13 hupper==1.9.1
14 ipaddress==1.0.23
14 ipaddress==1.0.23
15 importlib-metadata==0.23
15 jinja2==2.9.6
16 jinja2==2.9.6
16 jsonschema==2.6.0
17 jsonschema==2.6.0
17 pluggy==0.13.0
18 pluggy==0.13.1
18 pyasn1-modules==0.2.6
19 pyasn1-modules==0.2.6
19 pyramid-jinja2==2.7
20 pyramid-jinja2==2.7
20 scandir==1.10.0
21 scandir==1.10.0
Comments 0
You need to be logged in to leave comments. Login now